Issues sending emails to iCloud emails
Incident Report for Oznorts Status
Resolved
This incident has been resolved and emails are now being sent without error.
Posted Sep 19, 2020 - 09:50 PDT
Monitoring
We have implemented a temporary fix while the underlying issue is fixed.
Posted Sep 16, 2020 - 11:10 PDT
Update
We are still experiencing this partial outage. We expect the issue to be resolved in the next few days, but it may take up to two weeks to fully resolve.
Posted Sep 14, 2020 - 09:52 PDT
Identified
We are currently experiencing a partial outage with account emails sent to iCloud email address (@icloud.com, @mac.com, @me.com) due to an incorrect spam block on our IP addresses. We are currently working with the spam blacklist to remove our IP address and restore service. In the meantime, it's recommended that you login to our website for any notifications while we resolve this issue.
Posted Sep 12, 2020 - 09:33 PDT
This incident affected: oznorts.com (Account Emails).