Errors logging in to Portfolio Place
Incident Report for Oznorts Status
Resolved
This incident has been resolved and you can normally login to Portfolio Place now.
Posted Apr 12, 2021 - 11:52 PDT
Investigating
We are aware of an issue affecting Portfolio Place websites that results in errors when attempting to login and manage the portfolio. We are currently looking in to the issue and will update you as we identify and resolve the issue.
Posted Apr 12, 2021 - 11:44 PDT
This incident affected: Portfolio Place.